Вопрос задан 15.06.2023 в 10:45. Предмет Информатика. Спрашивает Черваков Саша.

Питон С N-го марта по K-атое марта (включительно) Саша работает над своим блогом. Если это

нечётное число (например, 5 марта), то Саша пишет текст для поста. Если число оканчивается на 2 (например, 2 или 12 марта), то Саша обрабатывает фото. Выведите на экран сначала количество дней в период с N по K число месяца, когда мальчик писал текст. Затем количество дней, когда мальчик обрабатывал фото. Пример: Формат входных данных Два целых числа: 0 < N < K < 32 Формат выходных данных Два числа через пробел: сначала количество дней для текста, потом количество дней для обработки фото.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Жумагазиев Азат.

Программа:

Python:

N = int(input('N = '))

K = int(input('K = ')) + 1

countText, countPhoto = 0, 0

for i in range(N, K):

   if i % 2 != 0:

       countText += 1

   if i % 10 == 2:

       countPhoto += 1

print(f'{countText} {countPhoto}')

Объяснение:

В начале вводятся значение переменным N и K с клавиатуры (к K добавляется 1, чтобы в будущем цикле не прибавлять значение + 1); регистрируются переменные countText и countPhoto, которым присваиваются значения 0. Циклом пробегаемся от N до K (включительно, так как уже прибавили единицу). Если число нечётное, то к значению переменной countText прибавляется единица, а если при делении числа на 10 получаем 2, то к значению countPhoto прибавляется единица. В конце выводятся числа через пробел с помощью f-строк.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно использовать цикл, проходящий по дням от N до K (включительно) и подсчитывающий количество дней для текста и обработки фото. Вот пример решения на языке Python:

python
# Ввод данных N = int(input("Введите начальное число (N): ")) K = int(input("Введите конечное число (K): ")) # Переменные для подсчета дней text_days = 0 photo_days = 0 # Цикл для подсчета дней for day in range(N, K+1): # Проверка на нечетное число для текста if day % 2 != 0: text_days += 1 # Проверка на окончание числа на 2 для фото elif day % 10 == 2: photo_days += 1 # Вывод результатов print(f"Дни для текста: {text_days}") print(f"Дни для обработки фото: {photo_days}")

Пример работы программы:

mathematica
Введите начальное число (N): 4 Введите конечное число (K): 13 Дни для текста: 5 Дни для обработки фото: 2

В этом примере Саша работал над текстом в 5 дней и обрабатывал фото в 2 дня.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос