Вопрос задан 15.06.2023 в 10:35. Предмет Информатика. Спрашивает Комова Екатерина.

(Язык Pascal) 1. Написать программу, которая запрашивает размерность двумерного массива, заполняет

его случайными числами от 4 до 9 и вычисляет сумму элементов, сумма индексов у которых четная. 2. Написать программу, которая запрашивает размерность двумерного массива, заполняет его случайными числами от -6 до 6 и заменяет на 0 значения отрицательных элементов массива.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Киловатый Григорий.

Ответ:

// Написать программу, которая запрашивает размерность двумерного массива,

// заполняет его случайными числами от 4 до 9 и

// вычисляет сумму элементов, сумма индексов у которых четная.

program massiv;

uses crt;

var a:array[1..10,1..10] of integer;{описание массива}

   i,j,n,s,sum:integer;

begin

  clrscr;

  randomize;{генератор случайных чисел}

  writeln ('введите размерность массива');

  readln(n);

  s:=0;

for i:=1 to n do begin

for j:=1 to n do begin

a[i,j]:= random(5)+5;

write(a[i,j]:3);

end;

writeln;

end;

writeln;

for i:=1 to n do begin

for j:=1 to n do begin sum:=i+j;

if (sum mod 2=0) then

s:=s+a[i,j];

end;

end;

writeln ('сумма элементов, сумма индексов у которых четная=',s);

end.

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Задача 1: Вычисление суммы элементов и суммы индексов с четными значениями

Для решения этой задачи на языке Pascal, мы можем использовать следующий алгоритм:

1. Запросить у пользователя размерность двумерного массива. 2. Создать двумерный массив с указанной размерностью. 3. Заполнить массив случайными числами от 4 до 9. 4. Вычислить сумму элементов и сумму индексов, у которых значение четное. 5. Вывести полученные значения на экран.

Вот пример кода на языке Pascal, который решает эту задачу:

```pascal program SumOfElementsAndIndexes;

uses crt;

var arr: array of array of Integer; rows, cols, i, j, sumElements, sumIndexes: Integer;

begin Randomize;

// Запросить размерность массива Write('Введите количество строк: '); ReadLn(rows); Write('Введите количество столбцов: '); ReadLn(cols);

// Создать двумерный массив SetLength(arr, rows, cols);

// Заполнить массив случайными числами от 4 до 9 for i := 0 to rows - 1 do begin for j := 0 to cols - 1 do begin arr[i, j] := Random(6) + 4; end; end;

// Вычислить сумму элементов и сумму индексов с четными значениями sumElements := 0; sumIndexes := 0;

for i := 0 to rows - 1 do begin for j := 0 to cols - 1 do begin if (arr[i, j] mod 2 = 0) then begin sumElements := sumElements + arr[i, j]; sumIndexes := sumIndexes + i + j; end; end; end;

// Вывести результаты WriteLn('Сумма элементов с четными значениями: ', sumElements); WriteLn('Сумма индексов с четными значениями: ', sumIndexes);

ReadLn; end. ```

Задача 2: Замена отрицательных элементов на 0

Для решения этой задачи на языке Pascal, мы можем использовать следующий алгоритм:

1. Запросить у пользователя размерность двумерного массива. 2. Создать двумерный массив с указанной размерностью. 3. Заполнить массив случайными числами от -6 до 6. 4. Заменить отрицательные элементы массива на 0. 5. Вывести полученный массив на экран.

Вот пример кода на языке Pascal, который решает эту задачу:

```pascal program ReplaceNegativeElements;

uses crt;

var arr: array of array of Integer; rows, cols, i, j: Integer;

begin Randomize;

// Запросить размерность массива Write('Введите количество строк: '); ReadLn(rows); Write('Введите количество столбцов: '); ReadLn(cols);

// Создать двумерный массив SetLength(arr, rows, cols);

// Заполнить массив случайными числами от -6 до 6 for i := 0 to rows - 1 do begin for j := 0 to cols - 1 do begin arr[i, j] := Random(13) - 6; end; end;

// Заменить отрицательные элементы на 0 for i := 0 to rows - 1 do begin for j := 0 to cols - 1 do begin if (arr[i, j] < 0) then begin arr[i, j] := 0; end; end; end;

// Вывести полученный массив на экран WriteLn('Исходный массив:'); for i := 0 to rows - 1 do begin for j := 0 to cols - 1 do begin Write(arr[i, j]:4); end; WriteLn; end;

ReadLn; end. ```

Надеюсь, эти примеры помогут вам решить задачи на языке Pascal. Если у вас возникнут дополнительные вопросы, не стесняйтесь задавать их!

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос