Вопрос задан 15.06.2023 в 09:11. Предмет Информатика. Спрашивает Алисултанов Мурад.

Написать программу, которая из заданного одномерного массива размерности N выводит только те

элементы, которые принадлежат отрезка [C, D]. (На паскале)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кусова Лиза.

Ответ:

program z;

var a: array [1..100] of integer;

i,N,C,D: integer;

begin

write('Введите количество элементов в массиве (N<=100): ');

readln(N);

write('Массив: ');

for i:= 1 to N do

begin

a[i]:= random(101)-50;

write(a[i],' ')

end;

writeln;

write('C = ');

readln(C);

write('D = ');

readln(D);

write('Элементы, которые принадлежат отрезку [',C,',',D,']: ');

for i:= 1 to N do

if (a[i]>=C) and (a[i]<=D) then write(a[i],' ')

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на Паскале для вывода элементов массива в заданном диапазоне

Вот пример программы на языке Паскаль, которая выводит только те элементы одномерного массива, которые принадлежат заданному диапазону [C, D]:

```pascal program ArrayElementsInRange;

const N = 10; // размерность массива C = 5; // начало диапазона D = 8; // конец диапазона

var arr: array[1..N] of Integer; // одномерный массив i: Integer; // переменная для цикла

begin // заполнение массива случайными числами Randomize; for i := 1 to N do arr[i] := Random(10);

// вывод элементов массива, принадлежащих диапазону [C, D] for i := 1 to N do begin if (arr[i] >= C) and (arr[i] <= D) then Write(arr[i], ' '); end;

Readln; end. ```

В этой программе мы объявляем одномерный массив `arr` размерности `N` и переменную `i` для цикла. Затем мы заполняем массив случайными числами с помощью функции `Random`. Далее, мы используем цикл `for` для перебора всех элементов массива и проверяем, принадлежит ли текущий элемент диапазону [C, D]. Если элемент принадлежит диапазону, то мы выводим его на экран с помощью процедуры `Write`.

Вы можете изменить значения `N`, `C` и `D` в программе, чтобы адаптировать ее под свои нужды.

Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос