написать программу на языке Паскаль : Вводим число 58, найти произведение цифр этого числа, а затем
найти остаток от деления 58 и полученного числа.Ответы на вопрос
Ответ:
program z;
var a,p,o:integer;
begin
read(a);
p:=(a div 10) * (a mod 10);
writeln(p);
o:=58 mod p;
write(o)
end.
Объяснение:
вводим двузначное число (read(a);)
находим произведение (p:=(a div 10) * (a mod 10);) первой цифры введенного двузначного числа (a div 10) и второй (a mod 10)
выводим полученное произведение на экран (writeln(p);)
находим остаток (o:=58 mod p;) от введённого числа (a) на полученное произведение цифр числа (p)
выводим полученный остаток на экран (write(o))
div - целочисленное деление
mod - остаток от целочисленного деления
58 / 10 = 5,8
58 div 10 = 5
58 mod 10 = 58 - 10 * 5 = 58 - 50 = 8
Программа на языке Паскаль для нахождения произведения цифр числа и остатка от деления
Для написания программы на языке Паскаль, которая находит произведение цифр числа и затем находит остаток от деления этого числа на полученное произведение, можно использовать следующий код:
```pascal program CalculateProductAndModulus; var number, digit, product, remainder: integer; begin // Ввод числа writeln('Введите число:'); readln(number); // Находим произведение цифр числа product := 1; while number > 0 do begin digit := number mod 10; product := product * digit; number := number div 10; end; writeln('Произведение цифр числа:', product); // Находим остаток от деления исходного числа на произведение цифр remainder := number mod product; writeln('Остаток от деления числа на произведение цифр:', remainder); end. ```
Этот код сначала запрашивает у пользователя ввод числа, затем находит произведение его цифр и, наконец, находит остаток от деления исходного числа на полученное произведение.
Надеюсь, это поможет! Если у вас есть еще вопросы или нужна дополнительная информация, не стесняйтесь спрашивать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
