Вопрос задан 15.06.2023 в 05:23.
Предмет Информатика.
Спрашивает Momot Vlada.
Напишите программу, которая вводит с клавиатуры одномерный массив из 5 целых чисел, меняет
отрицательные элементы на 0 и выводит новый массив на экран. Перед вводом каждого элемента на экране должна появляться подсказка с его.Ответы на вопрос
Отвечает Игнаев Родион.
Ответ:
program z;
var m:array [1..5] of integer;
i:integer;
begin
for i:=1 to 5 do
begin
write('m[',i,'] = ');
read(m[i]);
if m[i]<0 then m[i]:=0
end;
for i:=1 to 5 do write(m[i],' ')
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Python, которая реализует заданное условие:
```python # Создаем массив из 5 элементов arr = []
# Вводим элементы
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
