ПАСКАЛЬ!! Напишите программу, которая в символьной строке заменяет все нули на единицы и наоборот.
Остальные символы не должны измениться. Пример: Введите строку : 10a01Bx101 Ос Инверсия: 01a1 ОВхо101сОтветы на вопрос
Ответ:
program z;
var s:string;
i:integer;
begin
read (s);
for i:=1 to length(s) do
if s[i]='1' then s[i]:='0'
else if s[i]='0' then s[i]:='1';
write(s)
end.
Объяснение:
использовано:
цикл со счётчиком (length - количество символов в строке)
и
полный условный оператор с вложеным неполным условным оператором (if условие 1 then действие 1 else if условие 2 then действие 2)
Программа на языке Pascal для замены нулей на единицы и наоборот в строке
Для решения данной задачи на языке Pascal можно использовать следующий код:
```pascal program ReplaceZerosAndOnes; var inputString, resultString: string; i: integer; begin write('Введите строку: '); readln(inputString); resultString := ''; for i := 1 to length(inputString) do begin if inputString[i] = '0' then resultString := resultString + '1' else if inputString[i] = '1' then resultString := resultString + '0' else resultString := resultString + inputString[i]; end; writeln('Инверсия: ', resultString); end. ```
Этот код запрашивает у пользователя ввод строки, затем проходит по каждому символу в строке и заменяет нули на единицы, единицы на нули, оставляя остальные символы без изменений. Результат выводится на экран.
Например, если ввести строку "10a01Bx101", программа выведет "01a1Bx010".
Этот код решает поставленную задачу и может быть адаптирован для различных вариантов ввода и вывода.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
