Вопрос задан 12.06.2023 в 16:30. Предмет Информатика. Спрашивает Аптаев Еркош.

Помогите пж.мне нужно написать программу которая будет задавать вопросы и та выдавать ответы,если

ответ правильный то "правильно" если неправильный "неверныйответ" . И показывает количество правильных и неправильных ответов​ PYTHON
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гаджиева Сумайя.

Какие собственно вопросы, может как-то конкретнее опишите задание ?

Если так-то, то вы выдаёте вопрос на консоль, с вариантами ответа да/нет, с помощью оператора if, добавляете 1 к правильным или не правильным ответам( по желаю делаете проверку, если значение не является ни да, ни нет (else))

0 0
Отвечает Рузанов Кирилл.

import random

print("Привет, давай поиграем в игру!")

print("Я задам тебе несколько вопросов и ты должен ответить на них.")

print("Если ответ правильный, то я скажу 'Правильно!'.")

print("Если ответ неправильный, то я скажу 'Неверный ответ'.")

print("Готов? Начнем!")

print()

correct = 0

incorrect = 0

for i in range(5):

   num1 = random.randint(1, 10)

   num2 = random.randint(1, 10)

   answer = int(input("Сколько будет " + str(num1) + " + " + str(num2) + "? "))

   if answer == num1 + num2:

       print("Правильно!")

       correct += 1

   else:

       print("Неверный ответ.")

       incorrect += 1

print()

print("Правильных ответов:", correct)

print("Неправильных ответов:", incorrect)

print("Прощай!")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример простой программы на Python, которая задает вопросы, проверяет ответы и подсчитывает количество правильных и неправильных ответов:

python
def ask_question(question, correct_answer): user_answer = input(question) if user_answer.lower() == correct_answer.lower(): print("Правильно!") return True else: print("Неверный ответ!") return False def main(): questions = [ {"question": "Сколько будет 2 + 2?", "answer": "4"}, {"question": "Какое главное правило программиста?", "answer": "не писать наобум"}, {"question": "Какой язык мы учим?", "answer": "Python"} ] correct_count = 0 incorrect_count = 0 for q in questions: if ask_question(q["question"], q["answer"]): correct_count += 1 else: incorrect_count += 1 print("Правильные ответы:", correct_count) print("Неправильные ответы:", incorrect_count) main()

В этом примере есть функция ask_question, которая принимает вопрос и правильный ответ. Она запрашивает ответ пользователя, сравнивает его с правильным ответом (без учета регистра), и выводит соответствующее сообщение.

В функции main у нас есть список вопросов и ответов. Мы проходимся по каждому вопросу, используя функцию ask_question, и увеличиваем счетчик правильных или неправильных ответов в зависимости от результата.

В конце программы выводится общее количество правильных и неправильных ответов.

Вы можете добавить свои вопросы и ответы в список questions, а также изменить сообщения обратной связи в функции ask_question, чтобы лучше соответствовать вашим потребностям.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос