
ПОМОГИТЕ СРОЧНО!!! Составить программу для нахождения минимального элемента массива чисел и
посчитать их количество. [20, -3, 5,34,-78, 45,-8, 11,-78, 247,113,56,31,-78] Программу выполнить в среде программирования Паскаль.

Ответы на вопрос

Ответ:
const
N = 14;
var
numbers: array[1..N] of Integer;
min: Integer;
minCount: Integer;
i: Integer;
begin
numbers[1] := 20;
numbers[2] := -3;
numbers[3] := 5;
numbers[4] := 34;
numbers[5] := -78;
numbers[6] := 45;
numbers[7] := -8;
numbers[8] := 11;
numbers[9] := -78;
numbers[10] := 247;
numbers[11] := 113;
numbers[12] := 56;
numbers[13] := 31;
numbers[14] := -78;
min := numbers[1];
minCount := 1;
for i := 2 to N do
begin
if numbers[i] < min then
begin
min := numbers[i];
minCount := 1;
end
else if numbers[i] = min then
Inc(minCount);
end;
WriteLn('Минимальное число: ', min);
WriteLn('Количество минимальных чисел: ', minCount);
end.



Конечно! Вот пример программы на языке Pascal, которая находит минимальный элемент в заданном массиве чисел и подсчитывает их количество:
pascalprogram MinElementCount; const SIZE = 14; var numbers: array[1..SIZE] of Integer; i, minElement, count: Integer; begin numbers[1] := 20; numbers[2] := -3; numbers[3] := 5; numbers[4] := 34; numbers[5] := -78; numbers[6] := 45; numbers[7] := -8; numbers[8] := 11; numbers[9] := -78; numbers[10] := 247; numbers[11] := 113; numbers[12] := 56; numbers[13] := 31; numbers[14] := -78; minElement := numbers[1]; // Предполагаем, что первый элемент минимальный count := 0; // Находим минимальный элемент for i := 2 to SIZE do begin if numbers[i] < minElement then minElement := numbers[i]; end; // Подсчитываем количество элементов равных минимальному for i := 1 to SIZE do begin if numbers[i] = minElement then count := count + 1; end; writeln('Минимальный элемент: ', minElement); writeln('Количество элементов, равных минимальному: ', count); readln; end.
Программа объявляет массив numbers
с размером 14, инициализирует его заданными значениями и находит минимальный элемент с помощью цикла for
. Затем она использует еще один цикл for
, чтобы подсчитать количество элементов, равных минимальному. Наконец, программа выводит найденный минимальный элемент и количество элементов, равных ему.
Обратите внимание, что в Pascal индексация массива начинается с 1, поэтому мы используем array[1..SIZE]
для объявления массива и обращаемся к элементам с numbers[1]
до numbers[SIZE]
.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili