 
C++ Shell (сайт): Напишите программу: Человек вводит число, если оно равняется нулю программа
заканчивает свою работу. Если человек вводит число программа говорит это число чётное или не чётное, пока человек не введёт ноль 0
        0
         0
        0
    Ответы на вопрос
 
        #include <iostream>
using namespace std;
int main() {
int num;
while (true) {
cout << "Введите число: ";
cin >> num;
if (num == 0) {
break;
}
if (num % 2 == 0) {
cout << num << " четное" << endl;
} else {
cout << num << " нечетное " << endl;
}
}
return 0;
}
 0
                    0
                     0
                    0
                 
            Конечно, вот пример программы на языке C++, которая выполняет описанные вами действия:
cpp#include <iostream>
int main() {
    int number;
    while (true) {
        std::cout << "Введите число (для выхода введите 0): ";
        std::cin >> number;
        if (number == 0) {
            std::cout << "Программа завершена.";
            break;
        }
        if (number % 2 == 0) {
            std::cout << number << " - чётное число." << std::endl;
        } else {
            std::cout << number << " - нечётное число." << std::endl;
        }
    }
    return 0;
}
Эта программа запрашивает у пользователя ввод чисел. Если пользователь вводит 0, программа завершается. В противном случае, программа определяет, является ли введенное число чётным или нечётным, и выводит соответствующее сообщение. Затем программа повторно запрашивает ввод числа и продолжает свою работу до тех пор, пока пользователь не введёт 0.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			