Вопрос задан 08.06.2023 в 05:51. Предмет Информатика. Спрашивает Святцев Гавриил.

Помогите, пожалуйста. Нужно составить программу ( на паскаль) которая рисует отрезок с концами

(100,100),(100,200), если введено чётное число и рисует окружность (200,100) радиус 50, если введено нечётное число​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Липей Саня.

Ответ:

program draw_shape;

uses Graph;

var

gd, gm, x, y, radius, number: Integer;

begin

Write('Enter a number: ');

Readln(number);

gd := detect;

initgraph(gd, gm, '');

if (number mod 2 = 0) then

begin

x := 100;

y := 100;

line(x, y, x, y + 100);

end

else

begin

x := 200;

y := 100;

radius := 50;

circle(x, y, radius);

end;

readln;

closegraph;

end.

Объяснение:

пожалуйста сделай ответ лучшим)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке Паскаль, которая рисует отрезок или окружность в зависимости от введенного числа:

pascal
program DrawShape; uses Graph; var gd, gm, ErrorCode: smallint; choice: integer; begin // Инициализация графики gd := Detect; InitGraph(gd, gm, ''); // Проверка наличия графического режима ErrorCode := GraphResult; if ErrorCode <> grOk then begin Writeln('Ошибка графического режима: ', GraphErrorMsg(ErrorCode)); Halt(1); end; // Запрос выбора от пользователя Write('Введите число (чётное или нечётное): '); ReadLn(choice); // Отрисовка отрезка или окружности if choice mod 2 = 0 then Line(100, 100, 100, 200) // Рисуем отрезок else Circle(200, 100, 50); // Рисуем окружность // Задержка экрана ReadLn; // Закрытие графического режима CloseGraph; end.

Эта программа использует графическую библиотеку Graph для отображения отрезка или окружности на экране. Пользователю будет предложено ввести число, и в зависимости от того, является ли оно четным или нечетным, будет нарисован отрезок или окружность соответственно.

Обратите внимание, что для запуска этой программы вам понадобится подключить библиотеку Graph к вашей среде разработки Паскаль.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос