Вопрос задан 07.06.2023 в 08:25. Предмет Информатика. Спрашивает Федів Антон.

Напишите программу( в Beton), которую ищет среди целых чисел, принадлежащих числовому отрезку

(310705; 310729), простые числа, т.е. числа, имеющие ровно два различных натуральных делителя- единицу и само это число. Для каждого найденного числа Запишите его с новой строки; числа должны следовать в порядке возрастания. Например, в диапазоне ( 10; 20) ровно четыре простых числа- 11, 13, 17 и 19, поэтому для этого диапазона ответ должен быть таким: 11 13 17 19
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Шмелёва Кристина.

def is_prime(n):

   if n <= 1:

       return False

   if n <= 3:

       return True

   if n % 2 == 0 or n % 3 == 0:

       return False

   i = 5

   while i * i <= n:

       if n % i == 0 or n % (i + 2) == 0:

           return False

       i += 6

   return True

for num in range(310705, 310730):

   if is_prime(num):

       print(num)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке Python, который выполняет указанную задачу:

python
def is_prime(n): if n < 2: return False for i in range(2, int(n ** 0.5) + 1): if n % i == 0: return False return True start = 310705 end = 310729 for num in range(start, end + 1): if is_prime(num): print(num)

Программа использует функцию is_prime, чтобы проверить, является ли число простым. Затем она перебирает все числа в заданном диапазоне (start и end), и если число является простым, оно выводится на экран.

Пример вывода для указанного диапазона (310705; 310729):

310711 310721 310727

Обратите внимание, что это пример программы на языке Python, а не на языке Beton, так как Beton является вымышленным языком программирования, и мне неизвестны его особенности и синтаксис.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос