Вопрос задан 01.05.2023 в 08:50.
Предмет Информатика.
Спрашивает Евсюкова Виктория.
Даю 45 балов! Срочно! напишите программу на паскале, которая: С клавиатуры вводится натуральное
число N. Программа должна найти факториал этого числа (обозначается как N!) – произведение всех натуральных чисел от 1 до N. Пример: 5! = 1 * 2 * 3 * 4 * 5 = 120Ответы на вопрос
Отвечает Подколзина Вика.
Ответ:
program Programm;
var i,N,x:uint64;
begin
x:=1;
writeln('Введите число N');
readln(N);
for i := 1 to N do
begin
x:=x*i;
end;
writeln(x);
end.
Объяснение:
В var нужен uint для того чтобы вычислять большие числа;
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
program factorial;
var
N, i, f: integer;
begin
write('Введите число N: ');
readln(N);
f := 1; // начальное значение факториала
for i := 1 to N do
f := f * i; // умножаем текущее значение факториала на текущее число
writeln('Факториал числа ', N, ' равен ', f);
end.
0
0
var
N, i, f: integer;
begin
write('Введите число N: ');
readln(N);
f := 1; // начальное значение факториала
for i := 1 to N do
f := f * i; // умножаем текущее значение факториала на текущее число
writeln('Факториал числа ', N, ' равен ', f);
end.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
