Вопрос задан 07.05.2021 в 09:44. Предмет Информатика. Спрашивает Монаенков Влад.

Напишите программу в C Напишите программу, которая считывает значения двух переменных a и b,

затем меняет их значения местами (в переменной a должно быть записано то, что раньше хранилось в b, и наоборот) Решением задачи не является такой вид: ввод (a) ввод (b) вывод (b, a) Вводится два целых числа
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бадретдинова Лира.

#include <stdio.h>

void swap(float& a, float&b)

{

float tmp = a;

b = a;

a = tmp;

}

int main()

{

float a, b;

scanf_s("%f%f", &a, &b);

printf("%f %f", a, b);

swap(a, b);

printf("%f %f", a, b);

return 0;

}

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот пример программы на языке С, которая позволяет пользователю ввести два целых числа, затем меняет их значения местами:

c
#include <stdio.h> int main() { int a, b, temp; printf("Введите значение a: "); scanf("%d", &a); printf("Введите значение b: "); scanf("%d", &b); // меняем значения местами temp = a; a = b; b = temp; printf("a = %d, b = %d\n", a, b); return 0; }

Сначала мы объявляем три целочисленные переменные: a, b и temp. Затем мы запрашиваем у пользователя ввод двух чисел a и b, используя функцию scanf().

Далее мы меняем значения a и b местами, сохраняя значение a во временной переменной temp. Мы затем присваиваем b значение temp, которое содержит старое значение a, и наоборот.

Наконец, мы выводим новые значения a и b на экран, используя функцию printf(), и завершаем программу.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос