
Помогите, пожалуйста. Напишите программу:Программа генерирует случайное двузначное
число,необходимо вывести на экран это число и вывести на экран числа в обратном порядке (Например, если генерировалось число 45,то в обратном порядке 54)

Ответы на вопрос

#include <iostream>
#include <ctime>
using namespace std;
int main(int argc, char* argv[])
{
srand(time(NULL)); // рандомизация генератора случайных чисел
int rand_value = 10+ rand() % 80;
cout << "rand_value = " << rand_value << endl;
cout << "1-random number = " << rand_value % 10 << endl; // первый запуск генератора случайных чисел
cout << "2-random number = " << rand_value / 10 << endl; // второй запуск генератора случайных чисел
cout << "Resault: " << rand_value % 10 << rand_value / 10 << endl;
system("pause");
return 0;
}



Program n_1;
var x: integer;
begin
randomize;
x:=random(90)+10;
writeln(x);
writeln(x mod 10, x div 10);
end.



Конечно, вот пример кода на языке Python, который генерирует случайное двузначное число и выводит его на экран, а также выводит его в обратном порядке:
pythonimport random
# генерируем случайное двузначное число
number = random.randint(10, 99)
# выводим число на экран
print("Случайное двузначное число:", number)
# выводим число в обратном порядке
reverse_number = int(str(number)[::-1])
print("Число в обратном порядке:", reverse_number)
Обратите внимание на использование срезов строки [::-1]
для переворота числа в обратном порядке.


Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili