Вопрос задан 03.05.2021 в 08:35.
Предмет Информатика.
Спрашивает Черненкова Анжелика.
Задача на Pascal Требуется определить, бьет ли конь, стоящий на клетке с указанными координатами
(номер строки и номер столбца), фигуру, стоящую на другой указанной клетке. Входные данные Вводятся четыре числа: координаты коня и координаты другой фигуры. Все координаты - целые числа в интервале от 1 до 8. Выходные данные Программа должна вывести слово YES, если конь может побить фигуру за 1 ход, в противном случае вывести слово NO. входные данные 1 1 3 2 выходные данные YES входные данные 1 1 3 3 выходные данные NOОтветы на вопрос
Отвечает Мартинюк Марійка.
Var
x1, y1, x2, y2: integer;
begin
readln(x1, y1, x2, y2);
if abs(x1 - x2) + abs(y1 - y2) = 3 then
writeln('YES')
else
writeln('NO');
end.
x1, y1, x2, y2: integer;
begin
readln(x1, y1, x2, y2);
if abs(x1 - x2) + abs(y1 - y2) = 3 then
writeln('YES')
else
writeln('NO');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот решение задачи на Pascal:
arduinoprogram ChessKnight;
var
x1, y1, x2, y2: integer;
begin
readln(x1, y1, x2, y2);
if ((abs(x2 - x1) = 2) and (abs(y2 - y1) = 1)) or ((abs(x2 - x1) = 1) and (abs(y2 - y1) = 2)) then
writeln('YES')
else
writeln('NO');
end.
В этой программе мы считываем четыре числа - координаты коня и фигуры, а затем проверяем, может ли конь побить фигуру за один ход. Если да, то выводим "YES", иначе - "NO".
Чтобы проверить, может ли конь побить фигуру, мы используем две формулы:
Если разница между x-координатами коня и фигуры равна 2, а разница между y-координатами равна 1, то конь может побить фигуру.
Если разница между x-координатами коня и фигуры равна 1, а разница между y-координатами равна 2, то конь также может побить фигуру.
Обе эти формулы соответствуют правилу передвижения коня на шахматной доске. Если ни одна из них не выполняется, значит, конь не может побить фигуру за один ход.
Топ вопросов за вчера в категории Информатика
Информатика 47
Информатика 26
Информатика 32
Информатика 70
Информатика 43
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
