Надо написать программу, определяющую сколько слов в тексте начинается на букву "а". (Паскаль)
Ответы на вопрос
Ответ:
uses crt;
var st,buf:string;
k:integer;
begin
k:=0;
clrscr;
write('-> ');
readln(st);
repeat
if (st[1]=' ') or (length(st)=0) then while st[1]=' ' do delete(st,1,1)
else
begin
while (st[1]<>' ') and (length(st)>0) do
begin
buf:=buf+st[1];
delete(st,1,1);
end;
if upcase(buf[1])='A' then inc(k);
buf:='';
end;
until (length(st)=0) and (length(buf)=0);
writeln(k);
readln;
end.
Объяснение:
Program bykvaa;
Uses crt;
Var
a:string;
b,i:integer;
begin
writeln('Введите текст:');
readln(a);
if a[1]='а' then b:=b+1;
for i:=2 to length(a) do
begin
if a[i]='а' then if a[i-1]=' ' then b:=b+1;
end;
writeln('Количество слов в тексте, начинающихся на букву "а": ',b);
end.
Вот пример программы на языке Паскаль, которая считает количество слов, начинающихся на букву "а":
arduinoprogram countWordsStartingWithA;
var
text: string;
i, count: integer;
begin
writeln('Введите текст:');
readln(text);
count := 0;
for i := 1 to length(text) do
begin
if (text[i] = 'a') or (text[i] = 'A') then
begin
while (i <= length(text)) and (text[i] <> ' ') do
inc(i);
if i <= length(text) then
inc(count);
end;
end;
writeln('Количество слов, начинающихся на букву "а": ', count);
end.
Программа считывает текст, введенный пользователем, и проходит по всем символам текста, ища слова, начинающиеся на букву "а". Если программа находит букву "а", то она ищет следующий пробел или конец строки, чтобы определить конец слова. Если следующий символ после буквы "а" - это не пробел и не конец строки, то программа пропускает слово и продолжает поиск дальше.
В конце программа выводит количество найденных слов, начинающихся на букву "а".
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
