 
Вопрос задан 02.05.2021 в 06:14.
Предмет Информатика.
Спрашивает Сошкин Евгений.
Как написать в Паскале задачу,чтобы писать любой год и выдавалось кто ты по китайскому гороскопу
 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Боков Никита.
                
                   Надо задать,каким был,например 1900 год.Или какой-то иной меньше которого не зададут.Этот год условно считать нулеввым.Вводим любой год,находим разность между ним и 1900г(или тем,который выбран) и находится остаток от деления на 12.Например,вводим1990,тогда1990-1900=90.90mod 12=6 .И по этому значению берём 6-ой по кольцу год от того,которым был 1990.Через оператор выбора из многих (case)              
                                         0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Чтобы написать программу на Паскале, которая выдает знак китайского гороскопа для любого заданного года, можно использовать следующий код:
pascalprogram ChineseZodiac; var year, zodiac: integer; const RAT = 1; OX = 2; TIGER = 3; RABBIT = 4; DRAGON = 5; SNAKE = 6; HORSE = 7; GOAT = 8; MONKEY = 9; ROOSTER = 10; DOG = 11; PIG = 12; begin writeln('Введите год:'); readln(year); zodiac := (year - 4) mod 12; case zodiac of RAT: writeln('Ваш знак - Крыса'); OX: writeln('Ваш знак - Бык'); TIGER: writeln('Ваш знак - Тигр'); RABBIT: writeln('Ваш знак - Кролик'); DRAGON: writeln('Ваш знак - Дракон'); SNAKE: writeln('Ваш знак - Змея'); HORSE: writeln('Ваш знак - Лошадь'); GOAT: writeln('Ваш знак - Коза'); MONKEY: writeln('Ваш знак - Обезьяна'); ROOSTER: writeln('Ваш знак - Петух'); DOG: writeln('Ваш знак - Собака'); PIG: writeln('Ваш знак - Свинья'); end; end.
В этой программе пользователь будет запрашиваться ввести год, а затем программа будет использовать формулу (year - 4) mod 12, чтобы определить, какой знак китайского гороскопа соответствует введенному году. Затем программа выведет соответствующий знак на экран.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			