Вопрос задан 02.05.2021 в 03:56.
Предмет Информатика.
Спрашивает Вахрушев Саша.
В массиве,состоящем из 10 случайных чисел в интервале[-20;10],определите количество и сумму
элементов кратных 3.Pascal ABC.9классОтветы на вопрос
Отвечает Имельбаева Эльвиночка.
Var a:array [1..10] of integer;
i,k,s:integer;
begin
for i:= 1 to 10 do
a[i]:= Random(31)-20;
writeln(a);
for i:=1 to 10 do
if (a[i] <> 0)and(a[i] mod 3 = 0) then
begin
s:=s+a[i];
k:=k+1
end;
writeln('Количество элементов кратных 3 равно ',k,' и их сумма равна ',s)
end.
Ноль исключён из подсчёта элементов.
i,k,s:integer;
begin
for i:= 1 to 10 do
a[i]:= Random(31)-20;
writeln(a);
for i:=1 to 10 do
if (a[i] <> 0)and(a[i] mod 3 = 0) then
begin
s:=s+a[i];
k:=k+1
end;
writeln('Количество элементов кратных 3 равно ',k,' и их сумма равна ',s)
end.
Ноль исключён из подсчёта элементов.
Отвечает Островская Дарья.
Var a: array[0..10] of Integer;
i,sum,count: Integer;
begin
sum:=0;
count:=0;
for i:=0 to 9 do
begin
a[i]:=random(31)-10;
writeln('Число ',i+1,': ',a[i]);
end;
for i:=0 to 9 do
begin
if a[i] mod 3=0 then
begin
count:=count+1;
sum:=sum+a[i];
end;
end;
writeln('Сумма чисел: ',sum);
writeln('Кол-во: ',count);
end.
i,sum,count: Integer;
begin
sum:=0;
count:=0;
for i:=0 to 9 do
begin
a[i]:=random(31)-10;
writeln('Число ',i+1,': ',a[i]);
end;
for i:=0 to 9 do
begin
if a[i] mod 3=0 then
begin
count:=count+1;
sum:=sum+a[i];
end;
end;
writeln('Сумма чисел: ',sum);
writeln('Кол-во: ',count);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример кода на Pascal ABC, который решает задачу:
cssprogram countMultiplesOfThree;
var
arr: array[1..10] of integer;
i, count, sum: integer;
begin
count := 0;
sum := 0;
// заполнение массива случайными числами в интервале [-20;10]
for i := 1 to 10 do
begin
arr[i] := random(31) - 20;
writeln('arr[', i, '] = ', arr[i]);
// проверка, кратно ли число 3
if (arr[i] mod 3 = 0) then
begin
count := count + 1;
sum := sum + arr[i];
end;
end;
writeln('Количество элементов, кратных 3: ', count);
writeln('Сумма элементов, кратных 3: ', sum);
end.
Код генерирует массив arr из 10 случайных чисел в интервале [-20;10], выводит каждый элемент массива и подсчитывает количество и сумму элементов, кратных 3. Результаты выводятся на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
