Написать программу для Массива ( C# ): П1. Дан массив целых чисел из n элементов, заполненный
случайным образом числами из промежутка [-10,20]. Определить, есть ли в данном массиве положительные элементы, делящиеся на заданное число kОтветы на вопрос
//Для проверки результата вывел массив на экран
using System;
namespace App1
{
class Program
{
private static void Main()
{
const int x = -10;
const int y = 20;
int n, k;
Console.Write("Enter n: "); n = int.Parse(Console.ReadLine());
Console.Write("Enter k: "); k = int.Parse(Console.ReadLine());
Console.WriteLine($"{Environment.NewLine}Array:");
int counter = 0;
int[] array = new int[n];
Random rand = new Random();
for (int i = 0; i < array.Length; i++)
{
array[i] = rand.Next(x, y + 1);
if (array[i] > 0 && array[i] % k == 0) { counter++; }
Console.WriteLine($"{i + 1}. {array[i]}");
}
Console.Write(Environment.NewLine);
if (counter > 0) { Console.WriteLine($"В массиве {counter} элементов, соответствующих заданному условию."); }
else { Console.WriteLine("В массиве нет элементов, соответствующих заданному условию."); }
Console.ReadKey();
}
}
}


Код на C# для решения данной задачи:
csharpusing System;
class Program {
static void Main(string[] args) {
int n = 10; // количество элементов в массиве
int[] arr = new int[n];
Random rnd = new Random();
// заполнение массива случайными числами из промежутка [-10, 20]
for (int i = 0; i < n; i++) {
arr[i] = rnd.Next(-10, 21);
Console.Write(arr[i] + " ");
}
Console.WriteLine("\nEnter k:");
int k = int.Parse(Console.ReadLine());
bool found = false;
// поиск положительных элементов, делящихся на k
for (int i = 0; i < n; i++) {
if (arr[i] > 0 && arr[i] % k == 0) {
found = true;
Console.WriteLine("Found: " + arr[i]);
}
}
if (!found) {
Console.WriteLine("No elements found");
}
Console.ReadKey();
}
}
Пример вывода:
yaml3 -10 2 12 -1 -6 -8 -10 10 -6
Enter k:
5
Found: 10
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
