Вопрос задан 30.04.2021 в 00:58. Предмет Информатика. Спрашивает Рубчинский Дима.

Помогите написать программу в Python Задан двумерный массив А из 3-х строк и 5-и столбцов.

Составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. Вычислить произведение элементов полученного массива.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Дамбинов Слава.

Ответ:

Объяснение:

Обозначим заданный двумерный массив через A, искомый одномерный - через В, произведение всех элементов этого массива - M. Тогда:

B=[ ]

M=1

for i in range(5):

   n=0

   for j in range(3):

       if A[ j ][ i ]>0:

           n+=1

   B.append(n)

   M*=n

print(B,M)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать такую программу. Ниже приведен код на Python, который решает вашу задачу:

python
# Создаем двумерный массив A = [[-2, 3, 0, 1, -5], [5, 6, -1, -2, 0], [0, -4, 7, 2, -3]] # Инициализируем одномерный массив result = [0] * 5 # Считаем количество положительных элементов в каждом столбце for j in range(5): count = 0 for i in range(3): if A[i][j] > 0: count += 1 result[j] = count # Вычисляем произведение элементов одномерного массива product = 1 for i in range(5): product *= result[i] # Выводим результаты print("Исходный массив:") for row in A: print(row) print("Массив с количеством положительных элементов в столбце:") print(result) print("Произведение элементов полученного массива:") print(product)

В этом примере мы создаем исходный двумерный массив A, затем создаем одномерный массив result, который будет хранить количество положительных элементов в каждом столбце A. Затем мы используем два вложенных цикла для подсчета количества положительных элементов в каждом столбце и записываем результат в массив result. Наконец, мы вычисляем произведение элементов массива result и выводим результаты.

Вы можете изменить исходный массив A, но не забудьте также изменить размер массива result на соответствующее количество столбцов.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос