 
Вопрос задан 29.04.2021 в 09:44.
Предмет Информатика.
Спрашивает Ситников Миша.
1. Составить программу, распечатывающую все трехзначные числа, у которых цифры расположены в
порядке возрастания. 2. Найти произведение всех нечетных чисел, вводимых с клавиатуры. Признак окончания ввода цифра 0. 3. Вывести все квадраты натуральных чисел, не превосходящие данного числа N. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Краснопёров Михаил.
                
                   Var a,b,c:byte;              
Begin
For a:= 1 to 9 do
For b:= a+1 to 9 do
For c:= b+1 to 9 do
Write(a,b,c,' ')
End.
              
              
              
Var
P:real;
A:integer;
Begin
P:=1;
Repeat
Read(A);
if A mod 2 <> 0 then P:=P*A;
Until A = 0;
WriteLn('P = ',P)
End.
              
              
              
Var
N:integer;
Begin
Write('N = ');ReadLn(N);
For N:= 1 to N do
Write(N*N,' ')
End.
              
                                        Begin
For a:= 1 to 9 do
For b:= a+1 to 9 do
For c:= b+1 to 9 do
Write(a,b,c,' ')
End.
Var
P:real;
A:integer;
Begin
P:=1;
Repeat
Read(A);
if A mod 2 <> 0 then P:=P*A;
Until A = 0;
WriteLn('P = ',P)
End.
Var
N:integer;
Begin
Write('N = ');ReadLn(N);
For N:= 1 to N do
Write(N*N,' ')
End.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    - Программа на языке Python, которая распечатывает все трехзначные числа, у которых цифры расположены в порядке возрастания:
pythonfor i in range(123, 988):
    if str(i) == "".join(sorted(str(i))):
        print(i)
- Программа на языке Python, которая находит произведение всех нечетных чисел, вводимых с клавиатуры, и останавливается при вводе цифры 0:
pythonproduct = 1
while True:
    num = int(input("Введите число (0 для выхода): "))
    if num == 0:
        break
    elif num % 2 == 1:
        product *= num
print("Произведение всех нечетных чисел равно", product)
- Программа на языке Python, которая выводит все квадраты натуральных чисел, не превосходящие данного числа N:
pythonN = int(input("Введите число: "))
i = 1
while i**2 <= N:
    print(i**2)
    i += 1
Примечание: в решении задачи 1 мы начинаем с 123, так как это первое трехзначное число, у которого цифры расположены в порядке возрастания (1, 2, 3). Максимальное трехзначное число, у которого цифры расположены в порядке возрастания, равно 789 (7, 8, 9).
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			