 
составить программу в которой записать в массив N номера положительных элементов массива
(x1,x2...x15) 0
        0
         0
        0
    Ответы на вопрос
 
        var
N: array [1..15] of 1..15; {Массив, в который записываются номера положительных элементов массива х}
x: array [1..15] of real; //Массив х
i: integer; //Переменная для цикла
Number: integer; //Сколько номеров было записано
begin
Number:= 0; //Обнуляем счетчик номеров
for i:= 1 to 15 do //Вводим с клавиатуры массив х
begin
writeln('Введите ', i, ' элемент массива х');
readln(x[i]);
if x[i] > 0 then {Если введенный элемент массива х положительный, то прибавляем к счетчику добавленных номеров 1 и присваиваем соответствующему элементу массива N номер элемента}
begin
Number:= Number + 1;
N[Number]:= i;
end;
end;
write('Номера положительных элементов массива х: ');
for i:= 1 to Number do write(n[i], ' '); //Выводим записанные номера элементов
writeln; {Переход на новую строку, чтобы при следующем запуске программы информация выводилась с новой строки}
end.
 0
                    0
                     0
                    0
                 
            Вот пример программы на языке Python, которая записывает в массив номера положительных элементов массива x1, x2, ..., x15:
pythonx = [1, -2, 3, -4, 5, 6, -7, 8, 9, -10, -11, 12, 13, -14, 15]  # пример массива x
n = []  # пустой массив для хранения номеров положительных элементов
for i in range(len(x)):
    if x[i] > 0:  # если элемент положительный
        n.append(i)  # добавляем его номер в массив n
print(n)  # выводим массив n на экран
В этом примере мы создали массив x из 15 элементов, а затем прошли по всем его элементам с помощью цикла for. Если очередной элемент оказался положительным, то мы добавляем его номер (т.е. индекс) в массив n с помощью метода append(). В конце программы мы выводим полученный массив n на экран.
Вы можете изменить массив x и запустить программу, чтобы увидеть, как она работает с другими данными.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			