Вопрос задан 24.04.2021 в 17:12. Предмет Информатика. Спрашивает Kogut Vova.

В паскале Напишите программу, которая вводит с клавиатуры трёхзначное число и находит разность

между трёхзначным числом и числом, составленных из тех же цифр, но взятых в обратном порядке. Вывести на экран обратное число и полученную разность. Например, из числа 123 должно получиться число 321 и -198. Строки не использовать
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Волков Максим.

Ответ:

var a,b:integer;

begin

write('Введите трёхзначное число ');

readln(a);

b:=(a mod 10)*100+(a mod 100 div 10)*10+a div 100;

writeln('Обратное число ',b);

writeln('Разность ',a-b)

end.

Объяснение:

Для положительного трёхзначного числа.

Разбиваем на отдельные цифры используя операции целочисленного деления и остатка, умножаем полученные цифры на разряд.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Привет! Вот готовая программа на Pascal, которая решает задачу:

scss
program ReverseNumber; var inputNumber, reversedNumber, difference: integer; begin write('Введите трехзначное число: '); readln(inputNumber); reversedNumber := (inputNumber mod 10) * 100 + (inputNumber div 10 mod 10) * 10 + (inputNumber div 100); difference := inputNumber - reversedNumber; writeln('Обратное число: ', reversedNumber); writeln('Разность: ', difference); end.

Программа запрашивает у пользователя ввод трехзначного числа, затем находит обратное число и разность между исходным числом и обратным числом. Обратное число находится путем вычисления остатка от деления на 10, деления на 10 с остатком и деления на 100, а затем соединения этих цифр в нужном порядке. Результат выводится на экран с помощью функции writeln().

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос