Вопрос задан 21.04.2021 в 20:16.
Предмет Информатика.
Спрашивает Абдулова Анастасия.
Дано число часов H. Напишите программу, которая находит и выводит на экран количество полных дней и
оставшихся часов. паскаль........ срочно решениеОтветы на вопрос
Отвечает Зубак Яна.
var
H: Integer;
begin
Write ('Введите количество часов: ');
ReadLn (H);
WriteLn ('Полных дней = ', H div 24);
WriteLn ('Оставшиеся часы = ', H mod 24);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Pascal, которая решает данную задачу:
scssprogram DaysAndHours;
var
H, days, remainingHours: integer;
begin
write('Введите количество часов: ');
readln(H);
days := H div 24; // количество полных дней
remainingHours := H mod 24; // количество оставшихся часов
writeln('Полных дней: ', days);
writeln('Оставшихся часов: ', remainingHours);
end.
Программа запрашивает у пользователя количество часов H, затем находит количество полных дней и количество оставшихся часов, используя операторы деления и остатка от деления соответственно. Наконец, программа выводит результаты на экран.
Надеюсь, это поможет!
Топ вопросов за вчера в категории Информатика
Информатика 33
Информатика 32
Информатика 51
Информатика 94
Информатика 36
Информатика 22
Информатика 36
Информатика 12
Информатика 13
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
