Вопрос задан 16.04.2021 в 17:58. Предмет Информатика. Спрашивает Текеев Рашид.

Напишите программу на языке Pascal Разведчики-математики для того, чтобы опознать своих,

используют числовыепароли. Услышав число-пароль, разведчик должен возвести его в квадрат исказать в ответ первую цифры дробной части полученного числа. Напишитепрограмму, которая по полученному паролю (вещественному числу) вычисляетчисло-ответ.Пример:Введите пароль: 1.92Ответ: 6потому что 1,922 = 3,6864…, первая цифра дробной части – 6
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Анохина Анастасия.

Легче лёгкого:


program abc;

var

i:real;

s:string;

Begin

readLn(i);

i:= frac(i*i);

str(i,s);

write(s[3]);

End.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Программа на языке Pascal для вычисления числа-ответа по числовому паролю:

scss
program PasswordToNumber; var password, result: real; firstDigit: integer; begin writeln('Введите пароль:'); readln(password); // возводим пароль в квадрат и получаем первую цифру дробной части result := sqr(password); firstDigit := trunc(frac(result) * 10); writeln('Ответ: ', firstDigit); end.

В данной программе используются переменные password и result типа real для хранения входного пароля и вычисленного числа-ответа соответственно. Переменная firstDigit типа integer используется для хранения первой цифры дробной части числа-ответа.

Для вычисления числа-ответа программа сначала считывает пароль с помощью функции readln. Затем пароль возводится в квадрат с помощью функции sqr. Для получения первой цифры дробной части числа-ответа используется функция frac для получения дробной части результата и функция trunc для получения целой части этой дробной части. Умножение на 10 позволяет получить первую цифру дробной части числа-ответа.

Наконец, программа выводит число-ответ с помощью функции writeln.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос