Вопрос задан 16.04.2021 в 09:32.
Предмет Информатика.
Спрашивает Поднебесная Ксюша.
Написать программу в Паскале которая сначала должна обеспечить ввод 5 чисел в одномерный массив
затем вычислить количество четных и вывести сумму четных на экран a[1]=6 a[2]=5 a[3] a[4]=3 a[5]=2 количество четных чисел =3 cумма четных чисел=12.Ответы на вопрос
Отвечает Мальцев Никита.
//PascalABC.NET v3.3 1633
var arr: array [1..5] of integer;
begin
for var i:=1 to 5 do
arr[i]:=readinteger('Введите '+i+' элемент массива: ');
var sum:=0;
var number:=0;
for var i:=1 to 5 do
if arr[i] mod 2 = 0 then
begin
sum += arr[i];
number += 1;
end;
writeln('Количество четных чисел = '+number);
writeln('Сумма четных чисел = '+sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот готовый код на Паскале, который выполняет необходимые действия:
arduinoprogram CountEvenNumbers;
var
a: array[1..5] of integer;
i, count, sum: integer;
begin
// Ввод 5 чисел в массив
for i := 1 to 5 do
begin
write('Введите число a[', i, ']: ');
readln(a[i]);
end;
// Подсчет количества четных чисел и их суммы
count := 0;
sum := 0;
for i := 1 to 5 do
begin
if a[i] mod 2 = 0 then
begin
count := count + 1;
sum := sum + a[i];
end;
end;
// Вывод результатов на экран
writeln('Количество четных чисел = ', count);
writeln('Сумма четных чисел = ', sum);
readln; // Для того, чтобы программа не закрывалась сразу после вывода результатов
end.
При запуске программы пользователь будет приглашен ввести 5 чисел. Затем программа подсчитает количество четных чисел и их сумму, и выведет результаты на экран.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 33
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
