Вопрос задан 16.04.2021 в 00:47.
Предмет Информатика.
Спрашивает Мыцко Данил.
Помогите срочно в паскаль abc. 1. Написать программу нахождения среди чисел
от 1 до 100 всех пар чисел, для которых их сумма равна их произведению) 2. Написать программу вычисления куба суммы всех четных чисел от 2 до 100 3. Каждая бактерия делится на две через три минуты. В начальный момент имеется одна бактерия. Написать программу, определяющую, сколько будет бактерий через N минутОтветы на вопрос
Отвечает Немтырёва Ксения.
Это 3 задача
program tree;
var
i,t,n,c:integer;
begin
read(n)
c:=(n div 3)
i:=1
t:=1
while tbegin
i:=i+i
t:=t+1
end;
write(i);
end.
program tree;
var
i,t,n,c:integer;
begin
read(n)
c:=(n div 3)
i:=1
t:=1
while tbegin
i:=i+i
t:=t+1
end;
write(i);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
- Программа нахождения пар чисел, для которых их сумма равна их произведению:
arduinoprogram Pairs;
var
i, j, sum, prod: integer;
begin
for i := 1 to 99 do
for j := i+1 to 100 do
begin
sum := i + j;
prod := i * j;
if sum = prod then
writeln(i, ' and ', j, ' are a pair');
end;
end.
- Программа вычисления куба суммы всех четных чисел от 2 до 100:
bashprogram CubeSum;
var
i, sum: integer;
begin
sum := 0;
for i := 2 to 100 step 2 do
sum := sum + i;
writeln('Cube of sum of even numbers from 2 to 100 is ', sum * sum * sum);
end.
- Программа определения количества бактерий через N минут:
goprogram Bacteria;
var
n, i, count: integer;
begin
count := 1; // initial bacteria count
writeln('Enter the number of minutes:');
readln(n);
for i := 1 to n do
count := count * 2;
writeln('Number of bacteria after ', n, ' minutes is ', count);
end.
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
