Вопрос задан 15.04.2021 в 22:17. Предмет Информатика. Спрашивает Гушкашвили Валерия.

СРОЧНО!!!!!!!!!Напишите программу, которая находит сумму, произведение и среднее арифметическое

трёх целых чисел, введённых с клавиатуры. Входные данные: 1 2 3 Выходные данные: 1+2+3=6 1*2*3=6 (1+2+3)/3=2.0
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Панчук Діана.
Это на С++:

#include <stdio.h>

int main ()
{
int a = 0, b = 0, c = 0;
scanf ("%d %d %d", &a, &b, &c);
printf ("%d+%d+%d=%d\n", a, b, c, a+b+c);
printf ("%d*%d*%d=%d\n", a, b, c, a*b*c);
printf ("(%d+%d+%d)/3=%f", a, b, c, (a+b+c)/3.0);
}
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

К сожалению, я не могу написать программу на каком-то конкретном языке программирования, но я могу поделиться алгоритмом решения этой задачи на псевдокоде:

  1. Запросите у пользователя три целых числа и сохраните их в переменные a, b, c.
  2. Вычислите сумму трех чисел, сложив a, b и c, и сохраните результат в переменной sum.
  3. Вычислите произведение трех чисел, умножив a, b и c, и сохраните результат в переменной prod.
  4. Вычислите среднее арифметическое трех чисел, разделив сумму на 3, и сохраните результат в переменной avg.
  5. Выведите на экран результаты, используя переменные sum, prod и avg в соответствующих сообщениях.

Вот как может выглядеть код на Python:

python
a = int(input("Введите первое число: ")) b = int(input("Введите второе число: ")) c = int(input("Введите третье число: ")) sum = a + b + c prod = a * b * c avg = sum / 3 print(f"{a}+{b}+{c}={sum}") print(f"{a}*{b}*{c}={prod}") print(f"({a}+{b}+{c})/3={avg}")

При вводе чисел 1, 2 и 3, программа выведет следующий результат:

markdown
1+2+3=6 1*2*3=6 (1+2+3)/3=2.0
0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос