
Вопрос задан 13.04.2021 в 05:14.
Предмет Информатика.
Спрашивает Савлукова Светлана.
Pascal. Составить программу, которая вводит по строкам с клавиатуры двумерный массив и вычисляет
сумму его элементов. Нарисовать Блок-схему.

Ответы на вопрос

Отвечает Чипполина Лина.
Программа на паскале внизу




Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения данной задачи необходимо использовать циклы для перебора всех элементов массива и переменную для хранения суммы элементов.
Блок-схема решения задачи:
markdown┌─────────────┐
│ Начало программы │
└─────────────┘
│
▼
┌─────────────┐
│ Ввод размеров массива │
└─────────────┘
│
▼
┌─────────────┐
│ Создание массива │
└─────────────┘
│
▼
┌─────────────┐
│ Цикл по строкам массива │
└─────────────┘
│
▼
┌─────────────┐
│ Цикл по столбцам массива │
└─────────────┘
│
▼
┌─────────────┐
│ Суммирование элементов │
└─────────────┘
│
▼
┌─────────────┐
│ Вывод суммы │
└─────────────┘
│
▼
┌─────────────┐
│ Конец программы │
└─────────────┘
Программа на языке Pascal:
arduinoprogram sum_of_elements;
var
arr: array of array of integer;
sum, i, j, n, m: integer;
begin
write('Введите количество строк: ');
readln(n);
write('Введите количество столбцов: ');
readln(m);
SetLength(arr, n, m);
for i := 0 to n - 1 do
begin
for j := 0 to m - 1 do
begin
write('Введите элемент [', i+1, ',', j+1, ']: ');
readln(arr[i, j]);
end;
end;
sum := 0;
for i := 0 to n - 1 do
begin
for j := 0 to m - 1 do
begin
sum := sum + arr[i, j];
end;
end;
writeln('Сумма элементов массива равна ', sum);
end.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili