Вопрос задан 11.04.2021 в 16:32.
Предмет Информатика.
Спрашивает Суворова Даша.
Помогите составить программу в паскале: в компьютер вводятся числа числа от 1 до 9. Нужно
посчитать количество чётных и нечётных.Ответы на вопрос
Отвечает Шепетько Оля.
Program help;
uses Crt;
var a,cot,cpo:integer;
begin
ot:=0;po:=0;cot:=0;cpo:=0
repeat
writeln('Число: ');
readln(a);
if a<0 then begin ot:=ot+a; inc(cot);end else
if a>0 then begin po:=po+a; inc(cpo); end else
if a=0 then begin
writeln('Кол-во положительных чисел: ',cpo);
writeln('Кол-во отрицательных чисел: ',cot);
end;
until a=0;
readln;
end
uses Crt;
var a,cot,cpo:integer;
begin
ot:=0;po:=0;cot:=0;cpo:=0
repeat
writeln('Число: ');
readln(a);
if a<0 then begin ot:=ot+a; inc(cot);end else
if a>0 then begin po:=po+a; inc(cpo); end else
if a=0 then begin
writeln('Кол-во положительных чисел: ',cpo);
writeln('Кол-во отрицательных чисел: ',cot);
end;
until a=0;
readln;
end
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь составить программу на Паскале для подсчета количества четных и нечетных чисел введенных пользователем. Ниже приведен код программы:
scssprogram CountEvenOddNumbers;
var
num, evenCount, oddCount: integer;
begin
evenCount := 0;
oddCount := 0;
repeat
writeln('Введите число от 1 до 9 или 0 для завершения:');
readln(num);
if (num > 0) and (num < 10) then
begin
if num mod 2 = 0 then
evenCount := evenCount + 1
else
oddCount := oddCount + 1;
end;
until num = 0;
writeln('Количество четных чисел: ', evenCount);
writeln('Количество нечетных чисел: ', oddCount);
readln;
end.
Программа запрашивает у пользователя числа от 1 до 9 и подсчитывает количество четных и нечетных чисел. Чтобы завершить ввод чисел, пользователь может ввести 0. Результаты подсчета выводятся на экран.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
