Вопрос задан 09.04.2021 в 11:14. Предмет Информатика. Спрашивает Лаврентьева Карина.

Составьте программу которая считывает три числа введенные и выводит наибольшее из них.

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рамс Катя.

Ответ:

string chisla = "";

           int max = 0;

           Console.Write("Введите три числа через пробел: ");

           chisla = Console.ReadLine();

           int[] mas = new int[3];

           for (int i = 0; i < mas.Length; i++)

           {

               mas[i] = Convert.ToInt32(chisla.Split(' ')[i]);

           }

           for (int i = 0; i < mas.Length; i++)

           {

               if (mas[i] > max)

               {

                   max = mas[i];

               }

           }

           Console.WriteLine();

           Console.Write("Наибольшее число = {0}", max);

           

           Console.ReadKey();

Объяснение:

Язык не указан, написано на C#.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечный код программы будет зависеть от языка программирования, на котором вы планируете ее написать. Однако, вот примерный алгоритм решения этой задачи на языке Python:

python
# Считываем три числа, используя функцию input() a = float(input("Введите первое число: ")) b = float(input("Введите второе число: ")) c = float(input("Введите третье число: ")) # Сравниваем числа и выводим наибольшее из них if a > b and a > c: print("Наибольшее число: ", a) elif b > a and b > c: print("Наибольшее число: ", b) else: print("Наибольшее число: ", c)

Эта программа сначала считывает три числа с помощью функции input(), затем сравнивает их с помощью конструкции if-elif-else и выводит наибольшее из них с помощью функции print(). Обратите внимание, что я использую функцию float() для преобразования введенных значений в числа с плавающей точкой, чтобы программа могла корректно обрабатывать вещественные числа.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос