 
Вопрос задан 06.04.2021 в 12:38.
Предмет Информатика.
Спрашивает Шмелев Павел.
Написать программу,которая на вход получает два целых числа и определяет делится ли одно на другое
нацело. На выходе программа печатает False, если числа не делятся нацело и результат деления иначе. Все в паскале 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Ивченков Семён.
                
                   Var a,b:integer;              
begin
write('a='); readln(a);
write('b='); readln(b);
if a mod b = 0
then writeln(a,' / ',b,' = ',a div b)
else writeln(a mod b = 0);
end.
              
Пример 1:
a=20
b=5
20 / 5 = 4
              
Пример 2:
a=20
b=6
False
                                        begin
write('a='); readln(a);
write('b='); readln(b);
if a mod b = 0
then writeln(a,' / ',b,' = ',a div b)
else writeln(a mod b = 0);
end.
Пример 1:
a=20
b=5
20 / 5 = 4
Пример 2:
a=20
b=6
False
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на языке Pascal, которая выполняет описанные задачи:
arduinoprogram DivideIntegers;
var
  num1, num2, result: integer;
begin
  write('Введите первое число: ');
  readln(num1);
  
  write('Введите второе число: ');
  readln(num2);
  
  if num2 = 0 then
    writeln('Ошибка: нельзя делить на 0')
  else if num1 mod num2 = 0 then
    begin
      result := num1 div num2;
      writeln(num1, ' делится на ', num2, ' нацело. Результат: ', result);
    end
  else
    writeln(num1, ' не делится на ', num2, ' нацело.');
    
  readln; // чтобы окно не закрывалось сразу после выполнения
end.
Объяснение программы:
- Объявляем переменные num1,num2иresult, которые будут хранить вводимые пользователем числа и результат деления соответственно.
- Считываем два числа с помощью процедуры readln.
- Проверяем, не является ли второе число нулем. Если это так, выводим сообщение об ошибке и завершаем программу.
- Проверяем, делится ли первое число на второе нацело с помощью оператора mod(возвращает остаток от деления). Если да, вычисляем результат деления и выводим сообщение о том, что число делится нацело и какой результат получен.
- Если первое число не делится на второе нацело, выводим соответствующее сообщение.
- Программа останавливается и ждет, пока пользователь не нажмет клавишу Enter.
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			