
Написать программу: 1)Ввести целое число Х и определить, является ли число положительным или
отрицательным. 2)Ввести три числа a,b,c и вывести наибольшее max.

Ответы на вопрос

1.
program raf105;
var a:integer;
begin
write('Введите число: ');
readln(a);
if a<0
then writeln('Число отрицательное')
else writeln('Число положительное');
end.
2.
program raf105;
var a,b,c:integer;
begin
write('Введите 3 числа: ');
readln(a,b,c);
if (a>b) and (a>c)
then writeln('Большее ',a);
if (b>a) and (b>c)
then writeln('Большее ',b);
if (c>b) and (c>a)
then writeln('Большее ',c);
end.
Язык программирования PascalABC



К сожалению, я не могу написать программу непосредственно на вашем компьютере. Однако я могу предоставить вам код на нескольких языках программирования, который вы можете скопировать и вставить в свою среду разработки.
На Python это будет выглядеть следующим образом:
- Определение знака числа:
pythonx = int(input("Введите число: "))
if x > 0:
print("Число положительное")
elif x < 0:
print("Число отрицательное")
else:
print("Число равно нулю")
- Нахождение наибольшего числа:
lessa = int(input("Введите первое число: "))
b = int(input("Введите второе число: "))
c = int(input("Введите третье число: "))
max_number = a
if b > max_number:
max_number = b
if c > max_number:
max_number = c
print("Наибольшее число: ", max_number)
На JavaScript:
- Определение знака числа:
javascriptlet x = parseInt(prompt("Введите число: "));
if (x > 0) {
console.log("Число положительное");
} else if (x < 0) {
console.log("Число отрицательное");
} else {
console.log("Число равно нулю");
}
- Нахождение наибольшего числа:
javascriptlet a = parseInt(prompt("Введите первое число: "));
let b = parseInt(prompt("Введите второе число: "));
let c = parseInt(prompt("Введите третье число: "));
let max_number = a;
if (b > max_number) {
max_number = b;
}
if (c > max_number) {
max_number = c;
}
console.log("Наибольшее число: ", max_number);
Надеюсь, это поможет вам решить вашу задачу!


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili