
Дам много баллом!!!Напишите программу как в Паскале для задач: 1. С клавиатуры вводят координаты
точки, не лежащей на координатных осях ОХ и OY. Определить номер координатной четверти, в которой находится данная точка. 2. С клавиатуры вводятся четыре числа. Найти сумму наибольшего с наименьшим.

Ответы на вопрос

Ответ:
Объяснение:
1) program abc;
var x,y:real;
begin
readln(x,y);
if (x>0) then begin // проверка по x
if (y>0) then
writeln('1th'); // попадает в первую
if (y<0) then
writeln('4th'); // проверка в четвёртую
end
else begin
if (y>0) then
writeln('2nd'); // попадает во вторую
if (y<0) then
writeln('3th'); // попадает в третью
end;
end.
2)
program abc;
var A:array [1..4] of real; // ввод массива из четырёх чисел
i,max,min:shortint; // i - цикл, max - индекс максимального значения, min - минимального
s:real; // сумма
begin
readln(a[1]); // ввод первого значения
max:=1;
min:=1; // считаем что первое значение и минимум и максимум
for i:=2 to 4 do
begin
readln(A[i]); // ввод массива
if A[i]>a[max] then // Если данный элемент больше максимального
max:=i; // То записываем индекс этого элемента
if A[i]<A[min] then // аналогично с минимумом
min:=i;
end;
s:=A[max]+a[min]; // суммируем и выводим
write(s);
end.



Конечно, я могу помочь написать программу на Паскале для этих задач! Вот две программы, каждая соответствующая одной из задач:
Задача 1:
scssprogram coordinate_quadrant;
var
x, y: real;
begin
writeln('Введите координаты точки:');
readln(x, y);
if (x > 0) and (y > 0) then
writeln('Точка находится в первой координатной четверти')
else if (x < 0) and (y > 0) then
writeln('Точка находится во второй координатной четверти')
else if (x < 0) and (y < 0) then
writeln('Точка находится в третьей координатной четверти')
else if (x > 0) and (y < 0) then
writeln('Точка находится в четвертой координатной четверти')
else
writeln('Точка не лежит ни на одной из координатных четвертей');
end.
Задача 2:
rprogram max_min_sum;
var
a, b, c, d: integer;
max, min, sum: integer;
begin
writeln('Введите четыре числа:');
readln(a, b, c, d);
{ найдем максимальное и минимальное значение }
if a > b then
max := a
else
max := b;
if c > d then
min := d
else
min := c;
sum := max + min;
writeln('Сумма наибольшего и наименьшего чисел равна ', sum);
end.
Надеюсь, это поможет! Если у вас возникнут какие-либо вопросы, не стесняйтесь спрашивать.


Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili