Вопрос задан 04.04.2021 в 04:01.
Предмет Информатика.
Спрашивает Бухонов Миша.
1.составить программу вывода на экран квадрата числа, если число отрицательное, и куба если число
положительное. 2. составить программу вывода на экран чисел от 1 до 50. программа на язеке ПаскаляОтветы на вопрос
Отвечает Соколов Никита.
1.var a,b,c:integer;
begin
read(a);
If a<0 then
a:=a*a
else
a:=a*a*a;
writeln(a)
end.
2.var a,b,c:integer;
Begin
For c:=1 to 50 do
write(c,' ');
end.
begin
read(a);
If a<0 then
a:=a*a
else
a:=a*a*a;
writeln(a)
end.
2.var a,b,c:integer;
Begin
For c:=1 to 50 do
write(c,' ');
end.
Отвечает Филипенко Женя.
Var
i:integer;
BEGIN
readln(i);
if i>0 then
begin
writeln(i*i*i);
end else
begin
writeln(i*i);
end;
END.
var
i:integer;
BEGIN
for i=1 to 50 do
begin
writeln(i);
end;
END.
i:integer;
BEGIN
readln(i);
if i>0 then
begin
writeln(i*i*i);
end else
begin
writeln(i*i);
end;
END.
var
i:integer;
BEGIN
for i=1 to 50 do
begin
writeln(i);
end;
END.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
- Вот пример программы на языке Pascal, которая выводит на экран квадрат числа, если число отрицательное, и куб, если число положительное:
pascalprogram SquareOrCube; var number: integer; begin writeln('Введите число: '); readln(number); if number < 0 then writeln('Квадрат числа: ', number * number) else writeln('Куб числа: ', number * number * number); readln; end.
- А вот пример программы на языке Pascal, которая выводит на экран числа от 1 до 50:
pascalprogram NumbersFromOneToFifty; var i: integer; begin for i := 1 to 50 do writeln(i); readln; end.
Обратите внимание, что код Pascal чувствителен к регистру, поэтому следует убедиться, что ключевые слова (например, begin, end, if, else) написаны с использованием правильного регистра.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
