Вопрос задан 04.04.2021 в 00:11.
Предмет Информатика.
Спрашивает Волк Кристина.
Напишите программу нахождения НОК двух не нулевых чисел язык pascal
Ответы на вопрос
        Отвечает Блохин Иван.
                
                   Program LeastCommonMult; var m, n, prod: word; begin readln(m, n); prod := m * n; while m <> n do begin if m > n then begin m := m - n end else begin n := n - m end end; writeln(prod div m) end.              
                                        
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно! Вот пример программы на языке Pascal для нахождения НОК (наименьшего общего кратного) двух чисел:
arduinoprogram NOK;
var
  a, b, i, max: integer;
  nok: longint;
begin
  writeln('Введите два целых числа:');
  readln(a, b);
  if (a = 0) or (b = 0) then
  begin
    writeln('Ошибка: нулевые значения');
    halt;
  end;
  if a > b then
    max := a
  else
    max := b;
  i := max;
  repeat
    if (i mod a = 0) and (i mod b = 0) then
    begin
      nok := i;
      break;
    end;
    i := i + 1;
  until false;
  writeln('Наименьшее общее кратное (НОК) чисел ', a, ' и ', b, ' равно ', nok);
end.
В данной программе пользователь должен ввести два целых числа, которые нужно сравнить и найти их наименьшее общее кратное. Вначале программы мы проверяем, что числа не равны нулю, иначе выводится сообщение об ошибке и программа завершается. Затем мы определяем, какое из двух чисел больше, чтобы начать искать НОК с большего значения. Далее мы запускаем цикл итераций, проверяя каждое значение i на делимость на оба числа a и b. Если i делится на оба числа без остатка, то мы нашли НОК, прерываем цикл и выводим его значение.
Надеюсь, эта программа поможет вам находить НОК двух чисел в языке Pascal!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			