 
Вопрос задан 01.04.2021 в 09:50.
Предмет Информатика.
Спрашивает Кривзун Ярослав.
составить программу в С++, печатающую значение true , если указанное высказывание является истинным
, и false в противном случае : числа a и b выражают длины катетов одного прямоугольного треугольника , а c и d - другого . Эти треугольники являются подобными . на языке С ++ 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Буренкова Анастасия.
                
                   #include <iostream>              
using namespace std;
              
int main()
{
double a,b,c,d;
cout << "Enter 1st-triangle catheti here: " << endl;
cin >> a >> b;
cout << "Enter 2nd-triangle catheti here: " << endl;
cin >> c >> d;
              
bool podobie = ((a/c == b/d) || (a/d == b/c));
              
cout << boolalpha;
cout << podobie;
                  
cin.get();
cin.get();
return 0;
}
              
                                        using namespace std;
int main()
{
double a,b,c,d;
cout << "Enter 1st-triangle catheti here: " << endl;
cin >> a >> b;
cout << "Enter 2nd-triangle catheti here: " << endl;
cin >> c >> d;
bool podobie = ((a/c == b/d) || (a/d == b/c));
cout << boolalpha;
cout << podobie;
cin.get();
cin.get();
return 0;
}
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Вот пример программы на языке С++, которая сравнивает длины катетов и гипотенуз двух подобных треугольников и выводит значение true, если они соответствуют, и false, если нет:
c++#include <iostream>
using namespace std;
int main() {
    double a, b, c, d;
    cout << "Enter the length of the first triangle's legs (a, b): ";
    cin >> a >> b;
    cout << "Enter the length of the second triangle's legs (c, d): ";
    cin >> c >> d;
    if ((a / c == b / d) || (a / d == b / c)) {
        cout << "true" << endl;
    } else {
        cout << "false" << endl;
    }
    return 0;
}
В этой программе мы считываем значения a, b, c и d с помощью функции cin. Затем мы сравниваем отношения длин катетов и гипотенуз двух треугольников с помощью условного оператора if. Если эти отношения соответствуют, мы выводим "true", иначе мы выводим "false".
 0
                    0
                     0
                    0
                Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			