Вопрос задан 30.03.2021 в 00:18. Предмет Информатика. Спрашивает DELETED.

Написать программу которая по номеру урока выдаёт сообщение о его названии . Использовать команду

case
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Павлов Вадик.
Var
  N: integer;
Begin
  Write('Введите номер урока: ');ReadLn(N);
  Case N of
    '1':WriteLn('Математика');
    '2':WriteLn('Физика');
    '3':WriteLn('Химия');
    '4':WriteLn('Геометрия');
    '5':WriteLn('География');
    '6':WriteLn('Краеведенье');
  End;
End.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на языке программирования Java, которая использует команду switch-case для вывода названия урока по его номеру:

java
import java.util.Scanner; public class LessonNames { public static void main(String[] args) { Scanner input = new Scanner(System.in); System.out.print("Введите номер урока: "); int lessonNumber = input.nextInt(); String lessonName; switch (lessonNumber) { case 1: lessonName = "Введение в программирование"; break; case 2: lessonName = "Условные операторы"; break; case 3: lessonName = "Циклы"; break; case 4: lessonName = "Массивы"; break; case 5: lessonName = "Функции и методы"; break; default: lessonName = "Урок не найден"; } System.out.println("Название урока: " + lessonName); } }

В данном примере пользователь вводит номер урока, который сохраняется в переменной lessonNumber. Затем в зависимости от значения переменной lessonNumber программа выбирает соответствующее название урока и сохраняет его в переменную lessonName. Наконец, программа выводит название урока на экран. Если пользователь вводит номер урока, для которого нет соответствующего названия, программа выводит сообщение "Урок не найден".

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос