Вопрос задан 29.03.2021 в 13:48.
Предмет Информатика.
Спрашивает Смыслов Илья.
Напишите программу на языке Паскаль: Даны целые числа K и N (N >0). Вывести N раз число K.
Вычисление суммы чисел от 6 до 10. прошу пожалуйста помогитеОтветы на вопрос
Отвечает Гелей Саша.
1) Программа выводит N раз число K:
var k,n,i: Integer;
begin
writeln('Введите k');
readln(k);
writeln('Введите n');
readln(n);
for i:=1 to n do writeln(k);
end.
2) Сумма чисел от 6 до 10:
var a,sum: Integer;
begin
for a:=6 to 10 do
begin
Inc(sum,a);
end;
writeln(sum);
end.
var k,n,i: Integer;
begin
writeln('Введите k');
readln(k);
writeln('Введите n');
readln(n);
for i:=1 to n do writeln(k);
end.
2) Сумма чисел от 6 до 10:
var a,sum: Integer;
begin
for a:=6 to 10 do
begin
Inc(sum,a);
end;
writeln(sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Программа на языке Паскаль для вывода числа K N раз и вычисления суммы чисел от 6 до 10:
scssprogram Main;
var
K, N, i, sum: integer;
begin
write('Введите число K: ');
readln(K);
write('Введите число N: ');
readln(N);
for i := 1 to N do
writeln(K);
sum := 6 + 7 + 8 + 9 + 10;
writeln('Сумма чисел от 6 до 10: ', sum);
readln;
end.
Объяснение программы:
- Вводятся целые числа K и N с помощью процедуры
readln. - Запускается цикл
for, который повторяет командуwriteln(K)N раз и выводит число K на каждой итерации. - Вычисляется сумма чисел от 6 до 10 с помощью оператора
+и сохраняется в переменнойsum. - Результат выводится на экран с помощью команды
writeln. - Программа ждет ввода с клавиатуры, чтобы пользователь мог увидеть результат работы программы.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
