Вопрос задан 27.03.2021 в 07:43.
Предмет Информатика.
Спрашивает Гедгафова Алина.
составить программу вычесления суммысоставить программу вычесления суммы ряда s=4 в 1 степени+4 в 3
степени + 4 в 5 степени....+4 в 15 степениОтветы на вопрос
        Отвечает Головко Віталік.
                
                   Var              
k,j,i,s:integer;
begin
k:=1;
for i:=1 to 7 do
for j:=1 to 7 do
s:=s+4*k;
end;
k:=k+16;
end;
end.
Сам не компилировал, надеюсь ошибок нет, если есть то сори, просто разберись в цикле и сам всё поймешь.
                                        k,j,i,s:integer;
begin
k:=1;
for i:=1 to 7 do
for j:=1 to 7 do
s:=s+4*k;
end;
k:=k+16;
end;
end.
Сам не компилировал, надеюсь ошибок нет, если есть то сори, просто разберись в цикле и сам всё поймешь.
        Отвечает Черняк Максим.
                
                   Паскаль а не пасхаль если што              
                                        
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для вычисления суммы ряда можно воспользоваться циклом, который будет последовательно возводить число 4 в четные степени от 1 до 15 и прибавлять их к общей сумме. Вот как может выглядеть программа на языке Python:
bash# устанавливаем начальные значения
s = 0
power = 1
# запускаем цикл для возвведения числа 4 в четные степени
while power <= 15:
    s += 4 ** power  # добавляем 4 в степени power к сумме
    power += 2  # увеличиваем power на 2 для перехода к следующей четной степени
# выводим результат
print(s)
Эта программа сначала устанавливает начальное значение суммы s равным нулю и начальную степень power равной 1. Затем запускается цикл while, который будет выполняться до тех пор, пока power не превысит 15. Внутри цикла к сумме s добавляется число 4 в четной степени power, а затем power увеличивается на 2 для перехода к следующей четной степени. После окончания цикла программа выводит значение суммы s.
Результат выполнения программы будет равен 8738.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			