Вопрос задан 22.03.2021 в 22:25.
Предмет Информатика.
Спрашивает Невский Александр.
составьте программу позволяющую определить совпадают ли первая буква слова Х и последняя буква
слова У.(pascal abc.net)Ответы на вопрос
Отвечает Самсонова Адрияна.
var
x, y: string;
begin
write('Введите слово X: ');
readln(x);
write('Введите слово Y: ');
readln(y);
if x[1] = y[length(y)] then writeln('Буквы совпадают.')
else writeln('Буквы не совпадают.')
end.
x, y: string;
begin
write('Введите слово X: ');
readln(x);
write('Введите слово Y: ');
readln(y);
if x[1] = y[length(y)] then writeln('Буквы совпадают.')
else writeln('Буквы не совпадают.')
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal ABC.NET, которая определяет, совпадают ли первая буква слова X и последняя буква слова Y:
pascalprogram CheckFirstLastLetter; var X, Y: string; begin writeln('Введите слово X:'); readln(X); writeln('Введите слово Y:'); readln(Y); if (length(X) > 0) and (length(Y) > 0) and (upcase(X[1]) = upcase(Y[length(Y)])) then writeln('Первая буква слова X совпадает с последней буквой слова Y.') else writeln('Первая буква слова X не совпадает с последней буквой слова Y.'); readln; end.
В этой программе пользователю предлагается ввести два слова: X и Y. Затем программа проверяет, совпадают ли первая буква слова X и последняя буква слова Y. Если совпадение есть, выводится сообщение "Первая буква слова X совпадает с последней буквой слова Y". Если нет, выводится сообщение "Первая буква слова X не совпадает с последней буквой слова Y".
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
