Вопрос задан 18.03.2021 в 13:15.
Предмет Информатика.
Спрашивает DELETED.
Напишите программу в Турбо Паскале, которая выводит на экран фразу "Всем, привет!"
80 раз в таблице из 20 строк и 4 столбцов.Ответы на вопрос
Отвечает Грицук Митя.
Uses CRT;
ClrScr;
var
i, j: integer;
begin
for i := 1 to 20 do
begin
for j := 1 to 4 do Write('Всем, привет! ');
Writeln
end
end.
ClrScr;
var
i, j: integer;
begin
for i := 1 to 20 do
begin
for j := 1 to 4 do Write('Всем, привет! ');
Writeln
end
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Turbo Pascal, которая выводит фразу "Всем, привет!" 80 раз в таблице из 20 строк и 4 столбцов:
pascalprogram HelloWorldTable; const Rows = 20; Columns = 4; Message = 'Всем, привет!'; var i, j, count: integer; begin count := 0; for i := 1 to Rows do begin for j := 1 to Columns do begin writeln(Message); count := count + 1; if count >= 80 then exit; end; end; readln; end.
Программа использует два цикла: внешний цикл для строк и внутренний цикл для столбцов. Фраза "Всем, привет!" выводится на экран в каждой итерации внутреннего цикла. Переменная count используется для отслеживания количества выводов и прерывания выполнения программы после достижения 80 выводов.
Программа будет выводить фразу "Всем, привет!" в таблице 20 строк и 4 столбцов до тех пор, пока не будет достигнуто общее количество выводов равное или большее 80.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
