Написать программу на паскале. Заполнить массив: двадцатью первыми натуральными числами, делящимися
нацело на 13 или на 17 и большими 300 Пожалуйста! Очень надо!!!!!!!!!!Ответы на вопрос
var a:array [1..20] of integer;
i,k:integer;
BEGIN
k:=301;
for i:=1 to 20 do begin
while (k mod 17<>0) and (k mod 13<>0) do
k:=k+1;
a[i]:=k;
k:=k+1;
end;
for i:=1 to 20 do
write(a[i],' ');
end.
Конечно, вот пример программы на языке Паскаль, которая заполняет массив 21-ыми натуральными числами, делящимися нацело на 13 или на 17 и большими 300:
pascalprogram FillArray; const ArraySize = 21; var Numbers: array[1..ArraySize] of Integer; Count, i, number: Integer; begin Count := 0; number := 301; // начинаем с числа больше 300 while Count < ArraySize do begin if (number mod 13 = 0) or (number mod 17 = 0) then begin Count := Count + 1; Numbers[Count] := number; end; number := number + 1; end; // Выводим заполненный массив writeln('Заполненный массив:'); for i := 1 to ArraySize do writeln(Numbers[i]); readln; end.
Программа использует цикл while для заполнения массива Numbers числами, начиная с числа 301. Внутри цикла проверяется, делится ли текущее число на 13 или 17 без остатка. Если это выполняется, число добавляется в массив и переменная Count увеличивается на 1. Когда Count достигает значения ArraySize, цикл завершается.
Затем программа выводит заполненный массив на экран с помощью цикла for.
Надеюсь, это поможет!
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
