Написать программу на паскале к задаче Ученик 9 класса к уроку литературы должен выучить наизусть
три первые строфы первой главы романа А, С. Пушкина «Евгений Онегин», содержащие 42 строки. Сколько ему потребуется времени на выполнение этого задания, если первую строку он может запомнить за 5 секунд, а на запоминание каждой следующей строки ему требуется времени на 2 секунды больше, чем на запоминание предыдущей строки?Ответы на вопрос
Var str , time, thtime: integer;
Begin
str := 42;
thtime := 5;
While str>0 Do
Begin
str := str-1;
time := thtime+time;
thtime := thtime+2;
End;
write(time,' секунд');
End.
Вот пример программы на языке Pascal, которая решает данную задачу:
pascalprogram MemorizationTime; var FirstLineTime, AdditionalTime, TotalTime: Integer; LineNumber: Integer; begin FirstLineTime := 5; // время на запоминание первой строки (в секундах) AdditionalTime := 2; // дополнительное время на запоминание каждой следующей строки (в секундах) LineNumber := 42; // общее количество строк для запоминания TotalTime := FirstLineTime; // общее время инициализируется временем на запоминание первой строки // цикл для подсчета времени на запоминание каждой следующей строки for i := 2 to LineNumber do begin TotalTime := TotalTime + FirstLineTime + (i - 1) * AdditionalTime; end; writeln('Время, необходимое для запоминания всех строк:', TotalTime, ' секунд'); end.
Программа сначала задает значения переменных FirstLineTime (время на запоминание первой строки), AdditionalTime (дополнительное время на запоминание каждой следующей строки) и LineNumber (количество строк для запоминания).
Затем программа использует цикл для подсчета общего времени TotalTime на запоминание всех строк, учитывая время на каждую строку и дополнительное время, которое увеличивается на 2 секунды с каждой следующей строкой.
Наконец, программа выводит результат - общее время, необходимое для запоминания всех строк романа "Евгений Онегин".
Вы можете запустить эту программу на компиляторе Pascal и получить результат.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
