Вопрос задан 12.03.2021 в 00:21.
Предмет Информатика.
Спрашивает Перепелица Дарья.
Надо написать программу по нахождению в массиве минимальное и максимальное значение без команды
random. паскаль. СпасибоОтветы на вопрос
Отвечает Верещагина Катя.
Var a:array[0..4] of integer;
i,min,max:integer;
begin
for i:=0 to 4 do
read(a[i]);
max:=a[0];
min:=a[0];
for i:=1 to 4 do begin
if max<a[i] then
max:=a[i];
if min>a[i] then
min:=a[i];
end;
writeln('Максимальное число:',max);
write('Минимальное число:',min);
end
i,min,max:integer;
begin
for i:=0 to 4 do
read(a[i]);
max:=a[0];
min:=a[0];
for i:=1 to 4 do begin
if max<a[i] then
max:=a[i];
if min>a[i] then
min:=a[i];
end;
writeln('Максимальное число:',max);
write('Минимальное число:',min);
end
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль для нахождения минимального и максимального значения в массиве без использования функции random:
pascalprogram MinMaxArray; const SIZE = 10; var arr: array[1..SIZE] of Integer; i, minVal, maxVal: Integer; begin // Ввод значений массива writeln('Введите ', SIZE, ' целых чисел:'); for i := 1 to SIZE do readln(arr[i]); // Нахождение минимального и максимального значения minVal := arr[1]; maxVal := arr[1]; for i := 2 to SIZE do begin if arr[i] < minVal then minVal := arr[i]; if arr[i] > maxVal then maxVal := arr[i]; end; // Вывод результатов writeln('Минимальное значение в массиве: ', minVal); writeln('Максимальное значение в массиве: ', maxVal); readln; end.
В этом примере программа запрашивает у пользователя 10 целых чисел и затем находит минимальное и максимальное значение введенного массива. Она использует цикл для сравнения каждого элемента с текущим минимальным и максимальным значением, обновляя их при необходимости.
Примечание: Этот код предназначен для языка Паскаль (Pascal). Проверьте, соответствует ли ваша среда разработки этому языку, и внесите необходимые изменения, если используете другой язык программирования.
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
