Вопрос задан 11.03.2021 в 12:22.
Предмет Информатика.
Спрашивает Печерица Людмила.
Написать программу на языке паскаль, в которой определяется какому времени года принадлежит
введённый с клавиатуры порядковый номер месяца.За основу взято международное соглашение январь-1; декабрь-12.Ответы на вопрос
Отвечает Шарипова Диана.
Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1:writeln('Январь - Зима');
2:writeln('Февраль- Зима');
3:writeln('Март- Весна');
4:writeln('Апрель- Весна');
5:writeln('Май- Весна');
6:writeln('Июнь-Лето');
7:writeln('Июль- Лето');
8:writeln('Август- Лето');
9:writeln('Сентябрь-Осень');
10:writeln('Октябрь -Осень');
11:writeln('Ноябрь- Осень');
12:writeln('Декабрь - Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.
Либо упрощённый вариант:
Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1..2:writeln('Зима');
3..5:writeln('Весна');
6..8:writeln('Лето');
9..11:writeln('Осень');
12:writeln('Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1:writeln('Январь - Зима');
2:writeln('Февраль- Зима');
3:writeln('Март- Весна');
4:writeln('Апрель- Весна');
5:writeln('Май- Весна');
6:writeln('Июнь-Лето');
7:writeln('Июль- Лето');
8:writeln('Август- Лето');
9:writeln('Сентябрь-Осень');
10:writeln('Октябрь -Осень');
11:writeln('Ноябрь- Осень');
12:writeln('Декабрь - Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.
Либо упрощённый вариант:
Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1..2:writeln('Зима');
3..5:writeln('Весна');
6..8:writeln('Лето');
9..11:writeln('Осень');
12:writeln('Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.
Отвечает Шабала Олеся.
Int mesyac;
Console.WriteLine("Введите месяц:");
mesyac = Convert.ToInt32(Console.ReadLine());
if (mesyac == 12 || mesyac == 1 || mesyac == 2)
{
Console.WriteLine("Зима");
}
if (mesyac > 2 && mesyac =< 5)
{
Console.WriteLine("Весна");
}
if (mesyac > 5 && mesyac =< 8)
{
Console.WriteLine("Лето");
}
if (mesyac > 8 && mesyac =< 11)
{
Console.WriteLine("Осень");
}
Console.ReadKey());
Console.WriteLine("Введите месяц:");
mesyac = Convert.ToInt32(Console.ReadLine());
if (mesyac == 12 || mesyac == 1 || mesyac == 2)
{
Console.WriteLine("Зима");
}
if (mesyac > 2 && mesyac =< 5)
{
Console.WriteLine("Весна");
}
if (mesyac > 5 && mesyac =< 8)
{
Console.WriteLine("Лето");
}
if (mesyac > 8 && mesyac =< 11)
{
Console.WriteLine("Осень");
}
Console.ReadKey());
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Pascal, которая определяет времена года по введённому порядковому номеру месяца:
pascalprogram Seasons; var monthNumber: integer; begin writeln('Введите порядковый номер месяца (от 1 до 12): '); readln(monthNumber); case monthNumber of 1, 2, 12: writeln('Зима'); 3, 4, 5: writeln('Весна'); 6, 7, 8: writeln('Лето'); 9, 10, 11: writeln('Осень'); else writeln('Некорректный порядковый номер месяца'); end; readln; end.
Программа запрашивает у пользователя порядковый номер месяца и использует оператор case для определения времени года. Если введен корректный номер месяца от 1 до 12, программа выводит соответствующее время года. Если введено число, не попадающее в диапазон от 1 до 12, программа выдаст сообщение о некорректном порядковом номере месяца.
Обратите внимание, что в Паскале индексация начинается с 1, поэтому для определения времен года используются диапазоны чисел от 1 до 12.
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
