
Вопрос задан 08.03.2021 в 08:25.
Предмет Информатика.
Спрашивает Ключникова Дарья.
Помогите написать программу на паскаль. Ввести число и вывести строку – описание этого числа
«Отрицательные число», «Положительное число», «Нулевое число».

Ответы на вопрос

Отвечает Чернушкина Елена.
Var
a:integer;
begin
read(a);
if a > 0 then writeln('Положительное число') else if a < 0 then writeln('Отрицательное число') else writeln('Нулевое число');
end.
a:integer;
begin
read(a);
if a > 0 then writeln('Положительное число') else if a < 0 then writeln('Отрицательное число') else writeln('Нулевое число');
end.



Отвечает Каганцев Миша.
Var a:integer;beginWriteln('Введите число');Read(a);if a<0 then Writeln('Отрицательное число') elseif a=0 then writeln('Нулевое') else writeln('Положительное'); End.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на Pascal, которая позволит вам ввести число и вывести описание этого числа:
pascalprogram NumberDescription; var num: Integer; begin writeln('Введите число: '); readln(num); if num < 0 then writeln('Отрицательное число') else if num > 0 then writeln('Положительное число') else writeln('Нулевое число'); readln; end.
В этой программе используется переменная num
, в которую вы вводите число. Затем программа проверяет условия с помощью операторов if
и выводит соответствующее описание числа.
Надеюсь, это поможет вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Топ вопросов за вчера в категории Информатика

Информатика 47

Информатика 33

Информатика 67

Информатика 18

Информатика 25

Информатика 563

Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili