Вопрос задан 06.03.2021 в 16:54. Предмет Информатика. Спрашивает Гордусенко Вика.

C-Free . Напишите программу, которая вводит строку и выводит ее, сокращая каждый раз на 1 символ до

тех пор, пока в строке не останется 1 символ.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Галяс Світлана.

Ответ:

#include <stdio.h>

#include <conio.h>

using namespace std;

int main()

{

char *Arr = new char[500];

printf("Entered string \n");

gets_s((char*)Arr, 500);

int count = 0;

for (int i = 0; Arr[i] != '\0'; i++)

{

 count++;

}

if (count == 1)

{

 return 0;

}

else

{

 for (int j = count; j>0; j--)

 {

  for (int k = 0; k < j; k++)

  {

   

   printf( "%c", Arr[k]);

  }

  printf("\n");

 }

}

delete[] Arr;

_getch();

return 0;

}

Объяснение:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке C, который выполняет задачу, описанную вами:

c
#include <stdio.h> #include <string.h> int main() { char str[100]; // Максимальная длина вводимой строки - 100 символов printf("Введите строку: "); fgets(str, sizeof(str), stdin); int length = strlen(str); str[length - 1] = '\0'; // Удаление символа новой строки while (length > 1) { printf("%s\n", str); str[length - 2] = '\0'; // Удаление последнего символа length--; } return 0; }

В этом примере мы используем функцию fgets для чтения строки с учетом пробелов. Затем мы удаляем символ новой строки, чтобы строка была корректной. Далее, с помощью цикла while, мы выводим строку и затем удаляем последний символ, уменьшая длину строки на 1 каждую итерацию. Программа продолжает выводить строки, пока в строке не останется только один символ.

Обратите внимание, что в этом примере используется статический размер буфера str равный 100 символам. Вы можете изменить его в соответствии с вашими потребностями.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос