Вопрос задан 05.03.2021 в 23:07. Предмет Информатика. Спрашивает Саванович Юра.

Написать программу на Python, которая определяет количество натуральных трехзначных чисел, которые

делятся на 3, но не делятся на 4 и 9. В ответе нужен код программы и список этих чисел
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Майор Руслан.

a = []

s = 0

for i in range(100,1000):

   if i % 3 == 0 and i % 4 != 0 and i % 9 !=0:

       s += 1

       new_el = i

       a.append(i)

print(a)

print(s)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на Python, которая определяет количество натуральных трехзначных чисел, которые делятся на 3, но не делятся на 4 и 9, и выводит список этих чисел:

python
def count_numbers(): count = 0 numbers = [] for num in range(100, 1000): if num % 3 == 0 and num % 4 != 0 and num % 9 != 0: count += 1 numbers.append(num) return count, numbers count, numbers = count_numbers() print("Количество чисел:", count) print("Список чисел:", numbers)

Эта программа содержит функцию count_numbers(), которая перебирает все трехзначные числа от 100 до 999 и проверяет, выполняются ли условия деления на 3, но не деления на 4 и 9. Если число удовлетворяет условию, оно добавляется в список numbers, и счетчик count увеличивается. В конце программы выводится количество чисел и сам список чисел.

Запустив эту программу, вы получите результат, содержащий количество трехзначных чисел, которые делятся на 3, но не делятся на 4 и 9, и список самих чисел, удовлетворяющих условию.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос