Вопрос задан 04.03.2021 в 13:39.
Предмет Информатика.
Спрашивает Тамошина Альбина.
Составить программу-тренажер «Таблица умножения» для младших школьников в игровой форме. Обеспечить
накопление данных о работе пользователя и вывод на экран результирующего сообщения.Паскаль.Ответы на вопрос
Отвечает Фотин Сергей.
Program aaa;
var
a,b,c,i,z:integer;
begin
randomize;
z:=0;
for i:=1 to 10 do begin
a:=random(9)+1;
b:=random(9)+1;
write(a,'*',b,'=');
readln(c);
if(c=a*b) then inc(z);
end;
writeln('Из 10 заданий вы выполнили ',z,' заданий!');
end.
var
a,b,c,i,z:integer;
begin
randomize;
z:=0;
for i:=1 to 10 do begin
a:=random(9)+1;
b:=random(9)+1;
write(a,'*',b,'=');
readln(c);
if(c=a*b) then inc(z);
end;
writeln('Из 10 заданий вы выполнили ',z,' заданий!');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Привет! Вот пример программы-тренажера "Таблица умножения" на языке Pascal, который поможет младшим школьникам учиться игровым способом:
pascalprogram ТаблицаУмножения; uses SysUtils; var ПравильныеОтветы, ВсегоЗаданий: Integer; Ответ, ОжидаемыйОтвет: Integer; Продолжить: Boolean; И, Я: Integer; begin ПравильныеОтветы := 0; ВсегоЗаданий := 0; Продолжить := True; Writeln('Привет! Добро пожаловать в программу-тренажер "Таблица умножения"!'); Writeln('Введите "0", чтобы завершить программу.'); while Продолжить do begin И := Random(9) + 1; // Генерируем первый множитель от 1 до 9 Я := Random(9) + 1; // Генерируем второй множитель от 1 до 9 ОжидаемыйОтвет := И * Я; // Вычисляем ожидаемый ответ Write('Сколько будет ', И, ' умножить на ', Я, '? Ответ: '); Readln(Ответ); if Ответ = 0 then begin Продолжить := False; Break; end; ВсегоЗаданий := ВсегоЗаданий + 1; if Ответ = ОжидаемыйОтвет then begin Writeln('Правильно!'); ПравильныеОтветы := ПравильныеОтветы + 1; end else Writeln('Неправильно! Правильный ответ: ', ОжидаемыйОтвет); end; Writeln('Тренировка окончена!'); Writeln('Вы выполнили ', ВсегоЗаданий, ' заданий, из которых ', ПравильныеОтветы, ' были решены правильно.'); if ВсегоЗаданий > 0 then begin Writeln('Ваш процент правильных ответов: ', (ПравильныеОтветы / ВсегоЗаданий) * 100 : 0 : 2, '%'); end; end.
Эта программа генерирует случайные задания умножения для множителей от 1 до 9. Пользователь должен ввести ответ, а программа проверит его и выведет сообщение о том, правильный ли ответ был дан или нет. При вводе значения "0" программа завершится.
По окончании тренировки программа выведет общую статистику о проделанной работе, включая количество правильных ответов и процент прав
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
